How BCIT students can access NGRAIN online courses?

To access NGRAIN courses at BCIT you need to use IE 6 or higher. Other browsers such as Firefox, Safari, or Chrome are not supported. 

This is a solution from one of the BCIT students who solved the issue she encountered when accessing existing NGRAIN online courses using IE 11

"Click on Settings > Compatibility View Settings. Add the URL of the online NGRAIN course and close the Settings"

 

Did you find this article helpful?

Interact with our community

Browse forum